Solution Explorer Pane

The Solution Explorer enables you to manage your Vuser scripts. A solution contains Vuser scripts. Vuser scripts consist of script files, extra files (such as header files), runtime settings, parameters and replay runs. A solution can contain multiple scripts of different protocols.

The image below shows a Solution Explorer with two scripts.

 

To access

Do one of the following:

  • View > Solution Explorer
  • Press Ctrl + Alt + L
Important information
  • Solution Explorer is automatically displayed as part of the default layout.
  • You can move this pane to different areas of the Main User Interface. For details, see How to Modify the VuGen Layout.
  • Other main interface panes such as Output, Error and Snapshot synchronize their displays based on your location in the Solution Explorer.
  • You can double-click an asset to activate it in the editor area or right-click to examine quick operations available for that asset.
  • You can bundle scripts in a solution. For example you can bundle scripts related to one business process.

Note: The solution explorer cannot be imported into any of the existing management tools such as ALM or Controller.

See also

Understanding the Solution Explorer

Entity Used for Comments
Solution Container for all script objects. Give your solutions meaningful names, such as the name of the business process. The default solution name is "Untitled"
Scripts Creating, editing and debugging scripts.

Click once on a script, or one of its assets, to change the focus to that script. VuGen applies any actions, such as clicking replay, to the script in focus.

When any part of a script is selected, the menu options, toolbar and window panes display functionality relevant to the script's protocol. For example, if the script in focus is recorded in Web HTTP/HTML , the Recording Options button is displayed on the toolbar. However, if the script in focus is recorded in TruClient, the Develop Script button is displayed on the toolbar.

Double-click the script's action to open it in the editor.

You can drag and drop scripts (<scriptName>.usr) from the file directory to the Solution Explorer.

Extra Files Storing extra files that are used by the script.

The data contained in extra files can include:

  • Common utility functions used by the script (for example, code)

      You can add some types of extra utility function files to the parsing list to extend their functionality. For example, adding files enables "Go to Definition" functionality. See the Options Dialog Box.

  • Definition of constants and variables used by the script (for example, code)
  • Special assets used during script execution (such as .jpeg files)
  • Data files manipulated by script code during script execution
  • Additional files to be parsed. For details, see Create and Open Vuser Scripts.

Example: The following are examples of valid file types that can be added as extra files:

.ws,.h,.c.,dat,.ini,.vbs,.java,.js,.txt,.tux,.rec,.msc,.vdf,.xml,.xsl,.dtd,.html,.htm

You can drag and drop header files (<headerFileName.h>from your file directory. When you include files in the Extra Files node, these files are automatically included in a LoadRunner scenario.

You can edit extra files in the editor if the file type is included in Tools > Options > Scripting Tab > Script Management. Double click the extra file to open it in the Editor. For details on how to modify the list, see Scripting Options Tab.

Runtime Settings Defining the way a Vuser script runs. You can access runtime settings for a specific script from the Runtime Settings node in the Solution Explorer > <Script> > Runtime Settings. For details, see Runtime Settings Overview.
Parameters Creating and managing parameters. You can access parameters for a specific script from the Parameters node in the Solution Explorer > <Script> > Parameters. For details, see Parameterization Overview.
Replay Runs Enables you to access the Replay Summary Reports for each iteration in the replay.  

Back to top

Solution Explorer Structure and Context Menu Options

The following table lists the context menu options when working in the Solution Explorer.

UI Element and Description
Context Menu Options
Description
<Solution>

Container for scripts.

Add New Script

Creates a new script and adds it to the solution. For details, see Create a New Script Dialog Box.

Add Existing Script Adds an existing script to the solution.
Save All Scripts Saves the changes of all open scripts.
Close Solution Closes the current solution, along with its scripts, without saving the changes.
Save Solution As... Saves the solution with a new name or to a new location.
<Script>

Container for script assets including scripts actions, extra files, runtime settings and parameters.

Save Script

Saves the current script.

Save Script As...

Saves the script with a new name or new location, such as ALM.

Export to Template... Saves the script as a template. For details, see Create and Open Vuser Script Templates.
Remove Script

Deletes a script from the solution or from the file directory, if you enable the check box.

Select file to compare Compares two files using the highlighted asset as the primary file.
Compare to <filename>

Compares the primary file with the specified file.

Compare to external file...

Compares a file to a file outside of the solution. This option sets the highlighted file as the primary file and opens Windows Explorer to enable you to select the secondary file.

Select Folder to Compare

Compares one folder to another. The highlighted folder is the primary folder.

Compare to External Folder...

Compares the selected folder and the primary folder.

Open Script Folder

When you record, VuGen creates a series of configuration, data, and source code files. These files contain Vuser runtime and setup information. VuGen saves these files together with the script.

You can open the folder on the local disk where the script is saved. For scripts that are saved on a different storage location (such as ALM), this option opens the temporary folder on the local disk.

<Actions>

Container for individual actions including the default actions:

  • vuser_init
  • action
  • vuser_end
Create New Action

Adds a new script action block to your script.

Import Action Imports an action from an existing script.
Extra Files

Container for extra files associated with your script. You can access these extra files directly from VuGen.

Create New File

Creates a new file, and adds it to the Extra Files node of your script.

Add Files to Script Adds files to the Extra Files node of your script. The files that you add must already exist.

Add Files from Folders and Sub-folders

Adds the contents of folders and sub-folders to the Extra Files node of your script.

Runtime Settings  

Opens the runtime settings dialog box.

For details, see Runtime Settings Overview.
Parameters

Enables you to create, edit, and list parameters associated with your script.

Parameters list

Opens the Parameter List dialog box. For details, see Parameterization.

Create new parameter Opens the Select or Create Parameter dialog box.
Edit parameter Opens the Parameter Properties dialog box.
Configure parameter delimiter Opens the Parameter Delimiters Configuration dialog box.
Replay Runs

Enables you to display the Replay Summary report.

Open Replay Summary

Opens the Replay Summary in the Editor for selected iteration.

Back to top

See also: