Create a New Script Dialog Box

This dialog box enables you to create a new Vuser script.

To access
Do one of the following:
  • File > New Script and Solution
  • File > Add > New Script
  • Click the button in VuGen.
Relevant tasks

User interface elements are described below:

UI Element
Description
Category

The protocols to display in the Protocol pane and the type of script to create (for Single and Multiple Protocols):

  • User Templates. Displays any user-defined templates you have created. Available only if at least one user-defined template exists. For details, see How to Create and Open Vuser Script Templates.
  • Single Protocol. Shows all of the protocols. When you click OK, it creates a single protocol script using the selected protocol.
  • Multiple Protocols. Shows all of the protocols that can be included in a multi-protocol script. Select the check boxes adjacent to the protocols that you want to include.
  • Mobile. Create a script for a mobile application, using one of the mobile protocols: Mobile Application - HTTP/HTML, SMP, TruClient - Mobile Web, or TruClient - Native Mobile. For details, see How to Select a Recording Method for Mobile Applications.
  • Popular. Shows a list of the most commonly used protocols.
  • Recent. Shows a list of the most recently used protocols.
Protocol

The protocols included in the selected category.

Category Protocol List displays...

Single Protocol

A list of protocols.

You select one protocol.

Multiple Protocols

A list of protocols with a check box to the left of each protocol.

Select a check box to include the protocol in the Vuser script.

Mobile Protocols that record mobile applications.
Popular The most popular protocols in use in the user community.
Recent The protocols you have most recently used.
Filter

Enables you to filter the protocol list by entering text. For example, if you type "Java" into the Filter box, the Protocol list will display only those protocols that include the word Java.

Script Name

Enables you to specify the name of your script.

If you create a single protocol script,the default name is <protocol name>x where x represents the numerical sequence of the script created. For example, the name of the third script created for the Web- HTTP/HTML protocol would be WebHttpHtml3.

If you create a multi-protocol script, the default name is <protocol name_multi>x where protocol name is the first protocol you selected from the list and x represents the numerical sequence of the script created.

Location

Enables you specify the file location of your script. You can use the browse button to navigate to a location on your file system.

Tools > General > Projects and Solutions enables you to specify a default location.

Solution Name

This option is displayed only when a solution is not open in the Solution Explorer. You can specify a name for the solution. If you leave it blank, the default name is 'Untitled'.

Create a folder for this solution Enables you to create a folder for your solution.
Solution Target Displays the file path of the solution.
Displays the protocols in list view.
Displays the protocols in icon view.
Back to top